Error: System.ComponentModel.Win32Exception (0x80004005): Acceso denegado

Modificado el Mie, 5 Nov a 10:38 P. M.

Descripción del problema

Al intentar abrir el TPV de Ágora, puede aparecer el siguiente error:

System.ComponentModel.Win32Exception (0x80004005): Acceso denegado en System.Diagnostics.ProcessManager.OpenProcess(Int32 processId, Int32 access, Boolean throwIfExited) en System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited) en System.Diagnostics.Process.Kill() en IGT.POS.NativeBridge.Program.KillNativeBridgeIfNeeded(Int32 port) en IGT.POS.NativeBridge.Program.StartNativeBridge(CommandLineArgs commandLineArgs) en IGT.POS.NativeBridge.Program.Main(String[] args)

Causa

Este error ocurre cuando el sistema intenta iniciar el componente NativeBridge del TPV, pero ya existe otra instancia ejecutándose bajo un usuario diferente en el mismo equipo.

Solución

  1. Cerrar todas las sesiones de usuario activas en el equipo.

    • Cierra completamente las sesiones de otros usuarios que puedan estar abiertas en segundo plano (por ejemplo, desde el cambio rápido de usuario de Windows).

    • Puedes hacerlo desde el Administrador de tareas → pestaña “Usuarios” → clic derecho → Cerrar sesión.

  2. Verificar que no haya procesos de Ágora en ejecución:

    • Abre el Administrador de tareas (Ctrl + Shift + Esc).

    • Busca procesos relacionados con Ágora o NativeBridge y finalízalos si siguen activos.

¿Le ha sido útil este artículo?

¡Qué bien!

Gracias por sus comentarios

¡Sentimos mucho no haber sido de ayuda!

Gracias por sus comentarios

¡Háganos saber cómo podemos mejorar este artículo!

Seleccione al menos una de las razones
Se requiere la verificación del CAPTCHA.

Sus comentarios se han enviado

Agradecemos su esfuerzo e intentaremos corregir el artículo